<!DOCTYPE html><html lang="en-us" data-reactroot=""><head><meta name="google-site-verification" content="P13oAn8o8LB6FVCJWKsHWXvxfbR-SJrmvox6EgULpUs"/><meta name="ir-site-verification-token" value="-1270174611"/><meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0,maximum-scale=10.0"/><meta charSet="utf-8"/><meta name="ROBOTS" content="INDEX, FOLLOW"/><title>Dr. Pimple Popper Season 4 Episode 3 Recap</title><link rel="shortcut icon" type="image/png" href="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/auj4p7qsrkznkdstuufo.png"/><link rel="apple-touch-icon" type="image/png" href="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/auj4p7qsrkznkdstuufo.png"/><meta name="msapplication-square70x70logo" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/auj4p7qsrkznkdstuufo.png"/><meta name="msapplication-square150x150logo" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/auj4p7qsrkznkdstuufo.png"/><link rel="dns-prefetch" href="//kinja.com"/><link rel="dns-prefetch" href="//i.kinja-img.com"/><link rel="dns-prefetch" href="//x.kinja-static.com"/><link rel="dns-prefetch" href="//f.kinja-static.com"/><link rel="dns-prefetch" href="//www.googletagservices.com"/><link rel="dns-prefetch" href="//beacon.krxd.net"/><link rel="dns-prefetch" href="//pubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//stats.g.doubleclick.net"/><link rel="dns-prefetch" href="//tpc.googlesyndication.com"/><link rel="dns-prefetch" href="//pagead2.googlesyndication.com"/><link rel="dns-prefetch" href="//adservice.google.com"/><link rel="dns-prefetch" href="//securepubads.g.doubleclick.net"/><link rel="dns-prefetch" href="//static.adsafeprotected.com"/><link rel="dns-prefetch" href="//dt.adsafeprotected.com"/><link rel="dns-prefetch" href="//pixel.adsafeprotected.com"/><link rel="dns-prefetch" href="//tps10232.doubleverify.com"/><link rel="dns-prefetch" href="//pixel.mtrcs.samba.tv"/><link rel="dns-prefetch" href="//js-agent.newrelic.com"/><link rel="dns-prefetch" href="//c.amazon-adsystem.com"/><link rel="dns-prefetch" href="//aax.amazon-adsystem.com"/><link rel="preconnect" href="https://i.kinja-img.com"/><link rel="preconnect" href="//x.kinja-static.com"/><link rel="preconnect" href="//f.kinja-static.com" crossorigin="true"/><link rel="alternate" type="application/rss+xml" title="The Muse - All stories" href="https://themuse.jezebel.com/rss"/><meta name="keywords" content="Dr. Pimple Popper, TLC, Reality TV, The Muse"/><meta name="news_keywords" content="Dr. Pimple Popper, TLC, Reality TV, The Muse"/><meta name="twitter:url" content="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387"/><link rel="canonical" href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387"/><link rel="amphtml" href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387/amp"/><meta name="description" content="I put “BABY” in caps, because it’s a big baby. (And as a Daily Mail hat tip, naturally.) Imagine: “Congrats! It’s a...lipoma.” Another successful Pimple Popper delivery."/><meta property="og:title" content="Dr. Pimple Popper Removes a Lump the Size of a BABY From Man&#x27;s Shoulder"/><meta property="og:type" content="article"/><meta name="author" content=""/><meta property="og:url" content="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387"/><meta property="og:description" content="I put “BABY” in caps, because it’s a big baby. (And as a Daily Mail hat tip, naturally.) Imagine: “Congrats! It’s a...lipoma.” Another successful Pimple Popper delivery."/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="The Muse"/><meta property="og:image" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_675,pg_1,q_80,w_1200/dgw0lnnvff0fgkip7x84.png"/><meta property="fb:app_id" content="280492615405243"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@jezebel"/><meta name="twitter:title" content="Dr. Pimple Popper Removes a Lump the Size of a BABY From Man&#x27;s Shoulder"/><meta name="twitter:description" content="I put “BABY” in caps, because it’s a big baby. (And as a Daily Mail hat tip, naturally.) Imagine: “Congrats! It’s a...lipoma.” Another successful Pimple Popper delivery."/><meta name="twitter:image" content="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_675,pg_1,q_80,w_1200/dgw0lnnvff0fgkip7x84.png"/><script>
				window._fasttokenPerformanceMark = 'frontend.layout.header.user_token_fast';
				window._user = new Promise((resolve, reject) => {
					window._fasttoken = function (response) {
						if (window.performance) {
							window.performance.mark(window._fasttokenPerformanceMark);
						}
						if (response && response.meta &&response.meta.status === 200) {
							resolve(response.data);
						} else {
							reject(response ? response.meta : '');
						}
					};
				});
			</script><script src="https://kinja.com/api/profile/accountwithtoken?jsonp=_fasttoken&amp;newFollows=true" defer=""></script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');</script><style>.tp-iframe-wrapper{position:relative!important;}</style><script>
					_comscore = window._comscore || [];
					_comscore.push({
						c1: '2',
						c2: '6770184'
					});
					window._comscore = _comscore;
					(function(d,s,e,t){e=d.createElement(s);e.type='text/java'+s;e.async='async';e.src='http'+('https:'===location.protocol?'s://sb':'://b')+'.scorecardresearch.com/beacon.js';t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(e,t);})(document,'script');
				</script><script src="https://cdn.digitru.st/prod/1.4.4.beta/digitrust.min.js"></script><style data-styled="bzLsqw hVJsES iFVaRf cxfwkg fwjlmD fPqcTm fQjWOz cruvbL  eIjsbX gFCmRe kIbjiN eFBQmV ewAMZg buflah iIsiZI lgoJkk EMwih iSaTEN fRBjjk cZBgrX juDmih hhmmmD cIZLuj bYemXZ eSuPFB bYlXTp jgysUY elYELE GPChT eAOqtz eLxiAa iyxEIQ dTomTR dLONoQ gGQIUz eXTbge fWQdAR kgcYxS hebJFs AzvyH ktESSG ehkuKX etpvfO dhzTbZ iQFXup dVOasM fVlnpj cclgoe jIBiCM enJLjF lczDMb hdgju kHCVke iaqrWM jdPIHJ laOHsS jYvTqB fTjcDj esIpx bspgcg kFeogc bKrGzU vRmFv ctWecv izUYtn dsTWpc cLsyOJ ixUPOi kOsqmX kBeEqh fMEDzm wcAhP fwoJns dfSdTn bdPBiz dlcrWH cpgMQW hbcmGw bJgDUH etwVGZ ezwLgJ dqzDDd jpbKEQ fmiFaO bydMj lkqtha grWrOW bNRtrM kzkhwW dNAgCv dLRHcI cyUWWo fplIMg OMwVz foLDPX dPaBUR gqhndK jBsDWZ frTClM jzcQTJ cWiYXU kbNfCi cKaaXC gfolHV dUoECc hUFSvg iJyiXs hEuYft hJpRRP hFUXcT jWcsnW kqBBKi kieQv gPPElP ekkpks liWXlp iXYVqp eZvXLs eblHLt dciqNP hJcyvY gxHlor iwXbmg fwDNjy egRxyu eOMBOT gUlJSU jetHlK fbNnTF hPQZPo kSfANG nBxoz hjalAF bzrPWe jcgXjw fsIeMy jKmkQD jVTBel fGHfot gQKnCU bXAuVO cjCmmO tvyye bStdvX dBnbpo cEwyY dHZwOk cWglYt RFgyl iHpzjB" data-styled-version="4.3.2">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</style><style data-styled="gTwDaX kyiKbj kULIMn" data-styled-version="4.3.2">
/* sc-component-id: sc-keyframes-gTwDaX */
@-webkit-keyframes gTwDaX{from{-webkit-transform:translateX(-100%);-ms-transform:translateX(-100%);transform:translateX(-100%);}to{-webkit-transform:translateX(0);-ms-transform:translateX(0);transform:translateX(0);}} @keyframes gTwDaX{from{-webkit-transform:translateX(-100%);-ms-transform:translateX(-100%);transform:translateX(-100%);}to{-webkit-transform:translateX(0);-ms-transform:translateX(0);transform:translateX(0);}}
/* sc-component-id: sc-keyframes-kyiKbj */
@-webkit-keyframes kyiKbj{0%{z-index:0;opacity:0;}100%{z-index:10;opacity:1;}} @keyframes kyiKbj{0%{z-index:0;opacity:0;}100%{z-index:10;opacity:1;}}
/* sc-component-id: sc-keyframes-kULIMn */
@-webkit-keyframes kULIMn{0%{z-index:10;opacity:1;}100%{z-index:0;opacity:0;}} @keyframes kULIMn{0%{z-index:10;opacity:1;}100%{z-index:0;opacity:0;}}</style><style>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</style></head><body class="themusejezebel blog-group-jezebel blog-recirc-group-fmgNonSatire permalink en-US f_ads_a9_timeout_600_on f_adx_permalink_text_on f_amazon_aps_tag_on f_amazon_georedirect_on f_amp_skimlinks_on f_analyticstracking_on f_avclub_legacy_login_on f_bucketcookies_on f_chartbeat_video_on f_comments_compact_on f_commerce_permalink_module_on f_curation_on_storytype_on f_curation_toggle_on f_custom_header_on f_custom_kinja_standalone_on f_ddrum_on f_devcon_script_on f_dfp_lineitem_opts_on f_disable_fbia_rss_on f_donotcrawl_on f_editor_save_screen_update_on f_experimental_scores_on f_experiments_tool_on f_featured_video_toolbar_on f_full_width_headline_on f_fun_errorpages_on f_hide_ellipsis_on f_homepage_video_playlist_on f_infinite_promotion_on f_infinite_scroll_on f_kinja3_cards_phase2_on f_kinja3_cards_phase2_avatars_on f_kinja3_cards_phase3_on f_kinja_video_page_on f_legacy_embiggen_on f_lightbox_newsletter_script_on f_magma_experimental_permalinks_on f_magma_permalink_featured_on f_magma_permalink_roundup_on f_magma_permalink_standard_on f_magma_permalink_video_on f_magma_permalink_video_truncation_on f_magma_permalinkpath_redirect_on f_magma_render_permalinks_on f_magma_render_profiles_on f_magma_second_scroll_on f_magma_splashy_ad_logic_change_on f_meta_first_on f_mobilead_two_nodes_on f_more_from_go_on f_more_on_variant_a_on f_most_popular_sidebar_recirc_on f_native_recirc_magma_rendered_on f_native_sidebar_magma_rendered_on f_native_stream_magma_rendered_phase_2_on f_native_stream_magma_rendered_phase_3_with_excerpts_on f_new_permalink_a_on f_new_permalink_b_on f_new_static_stream_header_on f_new_story_page_boilerplates_on f_newmodalstyles_on f_permalink_paragraph_ads_on f_permalink_subscription_on f_piano_prod_on f_post_versioning_on f_prebid_on f_pure_save_button_on f_recirc_sidebar_on f_reply_nofollow_on f_restore_images_on f_reviewbox_alignment_full_bleed_on f_samba_for_simplereach_on f_scroll_vendor_on f_share_tools_on f_share_tools_footer_on f_sidebar_right_on f_simplereach_ad_tag_on f_simplereach_expanded_on f_slideshow_on f_smartcrop_on f_sticky_sidebar_video_on f_story_type_stream_below_6_on f_storytype_boilerplate_on f_subscription_module_amp_on f_subscription_module_applenews_on f_tradedesk_pixel_on f_truncated_video_ad_insertion_on f_video_upload_captions_on f_videojs_recentvideo_on f_videojs_video_permalink_on blog-group-jezebel"><div id="splashy-ad-container-top" class="splashy-ad-container no-overflow" style="display:none"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-SPLASHY_TOP ad-splashy-top" data-ad-unit="SPLASHY_TOP" data-targeting="{&quot;pos&quot;:&quot;splashytop&quot;}"></div></div><div id="trackers"></div><div><div class="js_mobile-nav"></div><div class="js_topbar sc-17y8tyw-0 bzLsqw"><div class="vuc0jk-0 hVJsES"><ul class="vuc0jk-1 iFVaRf"><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;avclub.com&quot;,{&quot;metric20&quot;:1}]]" href="//avclub.com">The A.V. Club</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;deadspin.com&quot;,{&quot;metric20&quot;:1}]]" href="//deadspin.com">Deadspin</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;gizmodo.com&quot;,{&quot;metric20&quot;:1}]]" href="//gizmodo.com">Gizmodo</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;jalopnik.com&quot;,{&quot;metric20&quot;:1}]]" href="//jalopnik.com">Jalopnik</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;jezebel.com&quot;,{&quot;metric20&quot;:1}]]" href="//jezebel.com">Jezebel</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;kotaku.com&quot;,{&quot;metric20&quot;:1}]]" href="//kotaku.com">Kotaku</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;lifehacker.com&quot;,{&quot;metric20&quot;:1}]]" href="//lifehacker.com">Lifehacker</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theroot.com&quot;,{&quot;metric20&quot;:1}]]" href="//theroot.com">The Root</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;thetakeout.com&quot;,{&quot;metric20&quot;:1}]]" href="//thetakeout.com">The Takeout</a></li><li class="vuc0jk-3 fPqcTm"></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;clickhole.com&quot;,{&quot;metric20&quot;:1}]]" href="//clickhole.com">Clickhole</a></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theonion.com&quot;,{&quot;metric20&quot;:1}]]" href="//theonion.com">The Onion</a></li><li class="vuc0jk-3 fPqcTm"></li><li class="vuc0jk-2 cxfwkg"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Network navigation&quot;,&quot;Network Blog Click&quot;,&quot;theinventory.com&quot;,{&quot;metric20&quot;:1}]]" href="//theinventory.com">The Inventory</a></li></ul></div></div><span class="overhang-wrapper sc-101yw2y-4 fQjWOz"><div class="js_header"><div class="sc-1f6xobn-10 cruvbL"><div class="sc-1f6xobn-8 eIjsbX"><div class="sc-1f6xobn-7 gFCmRe"><div class="sc-1f6xobn-0 kIbjiN"><div class="sc-1f6xobn-16 eFBQmV"><a href="//jezebel.com" title="Jezebel" class="sc-8vrmk6-0 ewAMZg"><div class="jezebel sc-2d8w30-0 buflah"><svg xmlns="http://www.w3.org/2000/svg" width="206" height="48" aria-label="Jezebel logo" viewBox="0 0 206 48"><path fill="#EC1238" fill-rule="evenodd" d="M1.66 0H13v30.8c0 3.93-3.33 10.38-7.46 13.3A17.73 17.73 0 0 1 0 47l.01-2.4c1.13-1.12 1.65-4.36 1.65-6.92V0zm18.35 0h23.47v9.07H31.3v3.45h11.88v6.65H31.3v3.71H44V32H20V0zm31.77 0h27.6c.03 1.4.07 6.84.07 6.84L67.1 23H80v9H51l.08-6.75L63.55 9.17H51.78V0zM181 0h11.08l.05 22.76 13.87-.04V32h-25V0zm-64 0h11.02c2.27 0 3.88-.01 5.75.22 2.37.3 5.24 2 6.55 3.34.9.92 2.59 3.48 2.32 5.72-.19 1.67-.83 3.75-3.26 6.01 4.56 2.65 4.62 6.89 4.62 6.82 0 7.59-7.12 9.83-10.86 9.83-3.9 0-16.12.06-16.12.06L117 0zm13.56 8a2.35 2.35 0 0 1 2.44 2.35c-.06 1.2-.3 2.13-1.25 2.43-.48.32-2 .2-2.75.18V8l1.56-.01zm-.17 10.03c2.01 0 3.61.94 3.61 2 0 2.9-1.6 2.97-5 2.97v-5c.51 0 .97.03 1.4.03zM86 0h23.48v9.07H97.3v3.45h11.88v6.65H97.3v3.71H110V32H86V0zm64 0h23.48v9.07H161.3v3.45h11.88v6.65H161.3v3.71H174V32h-24V0z"></path></svg></div></a><div class="sc-1f6xobn-17 iIsiZI">A Supposedly Feminist Website</div></div><div class="sc-1f6xobn-18 lgoJkk"><a href="/search" class="sc-1f6xobn-1 sc-1f6xobn-4 EMwih"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Search24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M15.31 1a7.69 7.69 0 1 1-5.06 13.48l-8.37 8.37a.51.51 0 1 1-.73-.72l8.37-8.38A7.69 7.69 0 0 1 15.31 1zm0 1.03a6.66 6.66 0 1 0 0 13.32 6.66 6.66 0 0 0 0-13.32z"></path></svg></span></a><div class="sc-1il3uru-2 sc-1f6xobn-20 fRBjjk"><span class="sc-1il3uru-3 cZBgrX"></span></div><a class="sc-1f6xobn-1 js_mobile-header-link sc-1f6xobn-2 juDmih"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" aria-label="Hamburger24 icon" viewBox="0 0 24 24"><path fill-rule="evenodd" d="M21.5 21a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5zm0-9a.5.5 0 0 1 .09 1H2.5a.5.5 0 0 1-.09-1H21.5z"></path></svg></span></a></div></div><nav class="dfwuc8-1 hhmmmD"><a data-key="latest" href="//jezebel.com/" class="dfwuc8-0 cIZLuj"><span>Latest</span></a><a data-tagcanonical="features" data-index="1" href="/c/features" class="dfwuc8-0 cIZLuj"><span>Features</span></a><a data-blogid="1633941729" data-index="2" href="https://themuse.jezebel.com" class="dfwuc8-0 bYemXZ"><span>The Muse</span></a><a data-blogid="1634876795" data-index="3" href="https://theslot.jezebel.com" class="dfwuc8-0 cIZLuj"><span>The Slot</span></a><a data-blogid="1634006394" data-index="4" href="https://pictorial.jezebel.com" class="dfwuc8-0 cIZLuj"><span>Pictorial</span></a><a data-tagcanonical="barf-bag" data-index="5" href="/c/barf-bag" class="dfwuc8-0 cIZLuj"><span>Barf Bag</span></a><a data-tagcanonical="dirt-bag" data-index="6" href="/c/dirt-bag" class="dfwuc8-0 cIZLuj"><span>Dirt Bag</span></a><a data-tagcanonical="video" data-index="7" href="/c/video" class="dfwuc8-0 cIZLuj"><span>Video</span></a></nav></div></div></div></div><div class="initWrappers sc-101yw2y-0 eSuPFB"><span class="js_custom-header-toolbar-container sc-101yw2y-2 bYlXTp"></span><span class="js_curation-toolbar-container sc-101yw2y-1 jgysUY"></span></div><span class="js_curation-editor-container sc-101yw2y-1 jgysUY"></span></span><div class="js_sticky-top-ad sc-101yw2y-5 elYELE"><div class="sc-1jotqfp-0 sc-1jotqfp-2 GPChT"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-TOP_BANNER ad-top-banner" data-ad-unit="TOP_BANNER" data-targeting="{&quot;pos&quot;:&quot;top&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a5c7d-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-top-banner"></span></div></div></div><div class="sc-157agsr-1 eAOqtz"><div class="js_privacy_policy"></div><div class="qsfpej-0 eLxiAa"><a class="ylqi26-0 iyxEIQ js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Story type click&quot;,&quot;https://themuse.jezebel.com/c/television&quot;]]" href="https://themuse.jezebel.com/c/television"><span class="vxl3c2-0 dTomTR">Television</span></a></div><header class="sc-1efpnfq-1 dLONoQ"><h1 class="sc-1efpnfq-0 gGQIUz"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink page click&quot;,&quot;Permalink page click - post header&quot;,&quot;standard&quot;]]" href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387">Dr. Pimple Popper Removes a Lump the Size of a BABY From Man's Shoulder</a></h1></header></div><div class="sc-157agsr-0 eXTbge"><aside class="ynugv2-2 fWQdAR"><div class="sc-101yw2y-3 kgcYxS"><div class="ynugv2-1 hebJFs"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_TOP ad-left-top" data-ad-unit="LEFT_TOP" data-targeting="{&quot;pos&quot;:&quot;left_top&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a73ac-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-top"></span></div></div><div id="sidebar_wrapper" class="ynugv2-3 AzvyH"><div class="js_sidebar_sticky_container sc-1ez0oyg-0 ktESSG"><div class="sc-1ez0oyg-1 etpvfO"><div><div class="js_sidebar-edit-video ynugv2-0 dhzTbZ"><div class="instream-native-video instream-permalink instream-native-video--desktop bxm4mm-0 dVOasM"></div></div><div id="trending_wrapper" class="ynugv2-0 iQFXup"><div id="trending-module" class="i2qujp-3 fVlnpj"><header><h2><strong>You</strong> may also like</h2></header><div class="i2qujp-2 cclgoe"><div class="sc-1m3f1n9-0 jIBiCM"><a class="sc-1m3f1n9-1 enJLjF js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position 1&quot;,&quot;https://jezebel.com/unfortunately-young-tom-steyer-could-get-it-1841066226&quot;,{&quot;metric16&quot;:1}]]" href="https://jezebel.com/unfortunately-young-tom-steyer-could-get-it-1841066226"><div class="ejta2c-0 kHCVke"><div><div><img alt="Unfortunately, Young Tom Steyer Could Get It" aria-label="Unfortunately, Young Tom Steyer Could Get It" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/z23fe6i8buhzzsuathuw.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/z23fe6i8buhzzsuathuw.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/z23fe6i8buhzzsuathuw.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="z23fe6i8buhzzsuathuw" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Unfortunately, Young Tom Steyer Could Get It" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div></a><a class="sc-1m3f1n9-1 lczDMb js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position 2&quot;,&quot;https://theslot.jezebel.com/the-making-of-a-liar-1841019811&quot;,{&quot;metric16&quot;:1}]]" href="https://theslot.jezebel.com/the-making-of-a-liar-1841019811"><div class="ejta2c-0 kHCVke"><div><div><img alt="The Making of a &#x27;Liar&#x27;" aria-label="The Making of a &#x27;Liar&#x27;" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/pu9ias46xbdbmfof6kpl.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/pu9ias46xbdbmfof6kpl.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/pu9ias46xbdbmfof6kpl.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="pu9ias46xbdbmfof6kpl" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="The Making of a &#x27;Liar&#x27;" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div></a><a class="sc-1m3f1n9-1 hdgju js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position 3&quot;,&quot;https://theglowup.theroot.com/interviewing-ayanna-pressley-about-her-alopecia-encoura-1841046375&quot;,{&quot;metric16&quot;:1}]]" href="https://theglowup.theroot.com/interviewing-ayanna-pressley-about-her-alopecia-encoura-1841046375"><div class="ejta2c-0 kHCVke"><div><div><img alt="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" aria-label="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/rfcvcolttgaqyjzpydca.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/rfcvcolttgaqyjzpydca.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/rfcvcolttgaqyjzpydca.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="rfcvcolttgaqyjzpydca" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div></a></div><div class="sc-17xh7h5-0 jdPIHJ"><div class="sc-17xh7h5-1 laOHsS"><div class="sc-17xh7h5-2 jYvTqB"></div></div><div class="sc-17xh7h5-1 laOHsS"><div class="sc-17xh7h5-2 fTjcDj"></div></div><div class="sc-17xh7h5-1 laOHsS"><div class="sc-17xh7h5-2 fTjcDj"></div></div></div><div class="i2qujp-0 esIpx"><div class="i2qujp-1 bspgcg"><a class="sc-15qf33u-5 kFeogc js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position main&quot;,&quot;https://jezebel.com/unfortunately-young-tom-steyer-could-get-it-1841066226&quot;,{&quot;metric16&quot;:1}]]" href="https://jezebel.com/unfortunately-young-tom-steyer-could-get-it-1841066226"><div class="sc-15qf33u-0 bKrGzU"><div class="ejta2c-0 kHCVke"><div><div><img alt="Unfortunately, Young Tom Steyer Could Get It" aria-label="Unfortunately, Young Tom Steyer Could Get It" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/z23fe6i8buhzzsuathuw.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/z23fe6i8buhzzsuathuw.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/z23fe6i8buhzzsuathuw.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="z23fe6i8buhzzsuathuw" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Unfortunately, Young Tom Steyer Could Get It" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div><div class="sc-15qf33u-2 sc-15qf33u-4 izUYtn"><strong>Jezebel</strong></div><h4 class="sc-15qf33u-1 dsTWpc">Unfortunately, Young Tom Steyer Could Get It</h4><div><div class="sc-15qf33u-2 sc-15qf33u-3 cLsyOJ"><strong>Emily Alford</strong></div><time class="sc-15qf33u-6 ixUPOi">Today 2:00PM</time></div></div></a><a class="sc-15qf33u-5 kFeogc js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position main&quot;,&quot;https://theslot.jezebel.com/the-making-of-a-liar-1841019811&quot;,{&quot;metric16&quot;:1}]]" href="https://theslot.jezebel.com/the-making-of-a-liar-1841019811"><div class="sc-15qf33u-0 vRmFv"><div class="ejta2c-0 kHCVke"><div><div><img alt="The Making of a &#x27;Liar&#x27;" aria-label="The Making of a &#x27;Liar&#x27;" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/pu9ias46xbdbmfof6kpl.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/pu9ias46xbdbmfof6kpl.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/pu9ias46xbdbmfof6kpl.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="pu9ias46xbdbmfof6kpl" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="The Making of a &#x27;Liar&#x27;" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div><div class="sc-15qf33u-2 sc-15qf33u-4 izUYtn"><strong>The Slot</strong></div><h4 class="sc-15qf33u-1 dsTWpc">The Making of a 'Liar'</h4><div><div class="sc-15qf33u-2 sc-15qf33u-3 cLsyOJ"><strong>Esther Wang</strong></div><time class="sc-15qf33u-6 ixUPOi">Yesterday 11:55AM</time></div></div></a><a class="sc-15qf33u-5 kFeogc js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Trending module click&quot;,&quot;position main&quot;,&quot;https://theglowup.theroot.com/interviewing-ayanna-pressley-about-her-alopecia-encoura-1841046375&quot;,{&quot;metric16&quot;:1}]]" href="https://theglowup.theroot.com/interviewing-ayanna-pressley-about-her-alopecia-encoura-1841046375"><div class="sc-15qf33u-0 ctWecv"><div class="ejta2c-0 kHCVke"><div><div><img alt="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" aria-label="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/rfcvcolttgaqyjzpydca.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/rfcvcolttgaqyjzpydca.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/rfcvcolttgaqyjzpydca.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="rfcvcolttgaqyjzpydca" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div><div class="sc-15qf33u-2 sc-15qf33u-4 izUYtn"><strong>The Glow Up</strong></div><h4 class="sc-15qf33u-1 dsTWpc">Interviewing Ayanna Pressley About Her Alopecia Encouraged Me to Go Public With Mine</h4><div><div class="sc-15qf33u-2 sc-15qf33u-3 cLsyOJ"><strong>Jessica Moulite</strong></div><time class="sc-15qf33u-6 ixUPOi">Today 12:30PM</time></div></div></a></div></div></div></div></div><div class="ynugv2-0 dhzTbZ"><div class="sc-1ez0oyg-0 ehkuKX"><div class="sc-1ez0oyg-1 etpvfO"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_RAIL ad-left-rail" data-ad-unit="LEFT_RAIL" data-targeting="{&quot;pos&quot;:&quot;left&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a6193-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-rail"></span></div></div></div></div></div></div></div><div class="ynugv2-0 dhzTbZ"><div class="sc-5f1ako-3 kOsqmX"><div class="sc-5f1ako-0 kBeEqh">Popular Deals on The Inventory</div><div class="sc-5f1ako-1 fMEDzm"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Popular commerce click&quot;,&quot;position 0&quot;,&quot;https://kinjadeals.theinventory.com/fridays-best-deals-dog-toys-tire-inflators-champagne-1841062954&quot;]]" href="https://kinjadeals.theinventory.com/fridays-best-deals-dog-toys-tire-inflators-champagne-1841062954?ks=commercerecirc_permalink"><div class="ejta2c-0 kHCVke"><div><div><img alt="Friday&#x27;s Best Deals: Dog Toys, Tire Inflators, Champagne Glasses, Water Flossers, and More" aria-label="Friday&#x27;s Best Deals: Dog Toys, Tire Inflators, Champagne Glasses, Water Flossers, and More" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/vbbisazsal4lkuyqmcuq.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/vbbisazsal4lkuyqmcuq.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/vbbisazsal4lkuyqmcuq.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="vbbisazsal4lkuyqmcuq" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Friday&#x27;s Best Deals: Dog Toys, Tire Inflators, Champagne Glasses, Water Flossers, and More" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div></a><div class="sc-5f1ako-2 wcAhP"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Popular commerce click&quot;,&quot;position 0&quot;,&quot;https://kinjadeals.theinventory.com/fridays-best-deals-dog-toys-tire-inflators-champagne-1841062954&quot;]]" href="https://kinjadeals.theinventory.com/fridays-best-deals-dog-toys-tire-inflators-champagne-1841062954?ks=commercerecirc_permalink"><h1 class="sc-759qgu-0 fwoJns">Friday's Best Deals: Dog Toys, Tire Inflators, Champagne Glasses, Water Flossers, and More</h1></a><span><div class="sc-1mep9y1-0 sc-1ixdk2y-0 dfSdTn"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/analuisasrz&quot;],[&quot;External Post Click&quot;,&quot;stream post click - 0&quot;,&quot;https://kinja.com/analuisasrz&quot;],[&quot;Kinja Deals click&quot;,&quot;position 0&quot;,&quot;https://kinja.com/analuisasrz&quot;,{&quot;metric23&quot;:1}]]" href="https://kinja.com/analuisasrz">Ana Suarez</a><span class="sc-1ixdk2y-1 bdPBiz">, </span></div><div class="sc-1mep9y1-0 sc-1ixdk2y-0 dfSdTn"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/tercius&quot;],[&quot;External Post Click&quot;,&quot;stream post click - 0&quot;,&quot;https://kinja.com/tercius&quot;],[&quot;Kinja Deals click&quot;,&quot;position 0&quot;,&quot;https://kinja.com/tercius&quot;,{&quot;metric23&quot;:1}]]" href="https://kinja.com/tercius">Tercius</a><span class="sc-1ixdk2y-1 bdPBiz">, </span></div><div class="sc-1mep9y1-0 sc-1ixdk2y-0 dfSdTn"><span class="sc-1ixdk2y-1 bdPBiz">and </span><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/coreyfoster&quot;],[&quot;External Post Click&quot;,&quot;stream post click - 0&quot;,&quot;https://kinja.com/coreyfoster&quot;],[&quot;Kinja Deals click&quot;,&quot;position 0&quot;,&quot;https://kinja.com/coreyfoster&quot;,{&quot;metric23&quot;:1}]]" href="https://kinja.com/coreyfoster">Corey Foster</a></div></span></div></div><div class="sc-5f1ako-1 fMEDzm"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Popular commerce click&quot;,&quot;position 1&quot;,&quot;https://kinjadeals.theinventory.com/get-your-dog-a-ton-of-christmas-toys-during-chewys-flas-1840340043&quot;]]" href="https://kinjadeals.theinventory.com/get-your-dog-a-ton-of-christmas-toys-during-chewys-flas-1840340043?ks=commercerecirc_permalink"><div class="ejta2c-0 kHCVke"><div><div><img alt="Get Your Dog a Ton Of Toys, Just Because, During Chewy&#x27;s Flash Sale" aria-label="Get Your Dog a Ton Of Toys, Just Because, During Chewy&#x27;s Flash Sale" srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/kwna1a0xoalc3dwgpb78.jpg 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/kwna1a0xoalc3dwgpb78.jpg 470w, , , , https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/kwna1a0xoalc3dwgpb78.jpg 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="kwna1a0xoalc3dwgpb78" data-format="jpg" data-default-transform="KinjaCenteredLargeAuto" data-width="450" data-relative="false" data-show-background="true" data-alt="Get Your Dog a Ton Of Toys, Just Because, During Chewy&#x27;s Flash Sale" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></div></div></a><div class="sc-5f1ako-2 wcAhP"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Popular commerce click&quot;,&quot;position 1&quot;,&quot;https://kinjadeals.theinventory.com/get-your-dog-a-ton-of-christmas-toys-during-chewys-flas-1840340043&quot;]]" href="https://kinjadeals.theinventory.com/get-your-dog-a-ton-of-christmas-toys-during-chewys-flas-1840340043?ks=commercerecirc_permalink"><h1 class="sc-759qgu-0 fwoJns">Get Your Dog a Ton Of Toys, Just Because, During Chewy's Flash Sale</h1></a><span><div class="sc-1mep9y1-0 sc-1ixdk2y-0 dfSdTn"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/analuisasrz&quot;],[&quot;External Post Click&quot;,&quot;stream post click - 1&quot;,&quot;https://kinja.com/analuisasrz&quot;],[&quot;Kinja Deals click&quot;,&quot;position 1&quot;,&quot;https://kinja.com/analuisasrz&quot;,{&quot;metric23&quot;:1}]]" href="https://kinja.com/analuisasrz">Ana Suarez</a></div></span></div></div></div></div><div class="ynugv2-0 dhzTbZ"><div class="sc-1ez0oyg-0 ehkuKX"><div class="sc-1ez0oyg-1 etpvfO"><div is="bulbs-dfp" class="ad-container dfp dfp-slot-LEFT_RAIL ad-left-rail" data-ad-unit="LEFT_RAIL" data-targeting="{&quot;pos&quot;:&quot;left&quot;}"></div><div class="bt-wrapper"><span data-uid="5d1b8a6193-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-left-rail"></span></div></div></div></div><div id="leftrail_dynamic_ad_wrapper"></div></div></div></aside><main class="sc-11qwj9y-0 dlcrWH"><div class="sc-11qwj9y-1 cpgMQW"><div class="js_kinja_notification"></div><script type="application/ld+json">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</script><div class="js_starterpost"><div class="sc-1fofo4n-0 hbcmGw"><div class="sc-83o472-1 bJgDUH"><div class="sc-83o472-0 etwVGZ"><div class="sc-1jc3ukb-0 ezwLgJ"><div class="sc-1jc3ukb-1 dqzDDd"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/richjuz&quot;]]" href="https://kinja.com/richjuz"><div><img srcSet="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_180,q_80,w_320/kwtueajkkxrpcpjyw9nq.png 320w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_264,q_80,w_470/kwtueajkkxrpcpjyw9nq.png 470w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/kwtueajkkxrpcpjyw9nq.png 800w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_675,q_80,w_1200/kwtueajkkxrpcpjyw9nq.png 1200w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,fl_progressive,g_center,h_900,q_80,w_1600/kwtueajkkxrpcpjyw9nq.png 1600w, https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_80,q_80,w_80/kwtueajkkxrpcpjyw9nq.png 80w" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" sizes="40px" data-chomp-id="kwtueajkkxrpcpjyw9nq" data-format="png" data-height="40" data-default-transform="AvatarSmallAuto" data-sizes="40px" data-width="40" data-relative="false" data-show-background="true" data-poster-src="" data-anim-src="" data-cropped="true" class="dv4r5q-2 iaqrWM"/></div></a></div><div class="sc-1jc3ukb-2 jpbKEQ"><div class="sc-1jc3ukb-3 fmiFaO"><div class="sc-1mep9y1-0 sc-1ixdk2y-0 dfSdTn"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Author click&quot;,&quot;https://kinja.com/richjuz&quot;]]" href="https://kinja.com/richjuz">Rich Juzwiak</a></div></div><div class="sc-1jc3ukb-6 bydMj"><time class="uhd9ir-0 lkqtha" dateTime="2020-01-17T15:00:00-05:00"><a class="js_meta-time js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink page click&quot;,&quot;Permalink page click - post header&quot;,&quot;standard&quot;]]" href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387">Today 3:00PM</a></time><div class="sc-1jc3ukb-4 grWrOW">•</div><div class="sc-1jc3ukb-5 bNRtrM"><div class="js_tag-dropdown"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Tag click&quot;,&quot;First tag click&quot;]]" href="/tag/dr-pimple-popper"><div class="wvv3zm-1 kzkhwW"><span>Filed to:</span><span class="wvv3zm-2 dNAgCv">Dr. Pimple Popper</span><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="ChevronDown icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M3.87 6.16a.5.5 0 0 0-.74.68l5.5 6c.2.21.54.21.74 0l5.5-6a.5.5 0 1 0-.74-.68L9 11.76l-5.13-5.6z"></path></svg></span></div></a></div></div></div></div></div></div><div class="sc-83o472-0 etwVGZ"><div class="sc-15g8630-1 dLRHcI"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink meta&quot;,&quot;Comment count click&quot;]]" href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387#replies"><div class="sc-15g8630-0 cyUWWo"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Bubble icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M5.59 12.69c.84.49.73 1.4-.08 2.95l.13-.1c.8-.58 1.84-1.47 1.96-1.65l.16-.23.28.05c.7.12 2.63 0 4.15-.54 2.4-.84 3.85-2.5 3.95-5.28.04-3.28-2.98-6.05-6.64-6.05-3.67 0-6.64 2.72-6.64 6.06 0 2.01.93 3.61 2.72 4.78zm-.46.71A6.33 6.33 0 0 1 2 7.9C2 4.08 5.36 1 9.5 1c4.13 0 7.55 3.14 7.5 6.91-.12 3.15-1.8 5.1-4.52 6.05-1.52.54-3.4.7-4.35.6-.4.41-1.25 1.13-1.98 1.66a5.6 5.6 0 0 1-1.19.72c-.78.26-.96-.38-.6-1.01.88-1.5 1.09-2.27.83-2.5l-.06-.03z"></path></svg></span><span>5</span></div></a><div class="sc-15g8630-0 cyUWWo"><div class="js_save-badge" data-state="{&quot;postId&quot;:&quot;1841066387&quot;,&quot;postPermalink&quot;:&quot;https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387&quot;,&quot;isBigger&quot;:true}" data-post-id="1841066387" data-post-permalink="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387"><div class="sc-1mn1yww-1 fplIMg"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Bookmark icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M4 15.21l4.63-5.05a.5.5 0 0 1 .74 0L14 15.21V2H4v13.21zm5-3.97l-5.13 5.6A.5.5 0 0 1 3 16.5v-15c0-.28.22-.5.5-.5h11c.28 0 .5.22.5.5v15a.5.5 0 0 1-.87.33L9 11.24z"></path></svg></span><div class="sc-1mn1yww-0 OMwVz">Save</div></div></div></div></div><div class="sc-83o472-2 foLDPX"><div class="js_share-tools" data-position="top"><div class="sc-17x7c2u-3 dPaBUR"><a href="https://facebook.com/sharer.php?u=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3Dthemusejezebel_facebook" title="Share to Facebook" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Facebook icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M17 9.05A8.02 8.02 0 0 0 9 1C4.58 1 1 4.6 1 9.05A8.04 8.04 0 0 0 7.75 17v-5.62H5.72V9.05h2.03V7.28c0-2.02 1.2-3.14 3.02-3.14.88 0 1.8.16 1.8.16v1.98h-1.02c-.99 0-1.3.62-1.3 1.26v1.5h2.22l-.36 2.34h-1.86V17A8.04 8.04 0 0 0 17 9.05"></path></svg></span></span></a><a href="https://twitter.com/share?text=Dr.%20Pimple%20Popper%20Removes%20a%20Lump%20the%20Size%20of%20a%20BABY%20From%20Man&#x27;s%20Shoulder&amp;amp;via=@jezebel&amp;amp;url=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3Dthemusejezebel_twitter" title="Share to Twitter" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Twitter icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M12.46 1.13c-2.04 0-3.7 1.78-3.7 3.97 0 .31.04.62.1.9a10.26 10.26 0 0 1-7.6-4.15A4.2 4.2 0 0 0 2.4 7.16a3.5 3.5 0 0 1-1.68-.5v.05a3.92 3.92 0 0 0 2.97 3.9 3.45 3.45 0 0 1-1.67.07 3.74 3.74 0 0 0 3.45 2.76A7.08 7.08 0 0 1 0 15.1a9.92 9.92 0 0 0 5.66 1.79c6.8 0 10.5-6.06 10.5-11.32v-.51A7.85 7.85 0 0 0 18 2.99c-.66.32-1.37.53-2.12.63a3.95 3.95 0 0 0 1.62-2.2c-.71.45-1.5.78-2.34.96a3.57 3.57 0 0 0-2.7-1.25"></path></svg></span></span></a><a href="mailto:?subject=Dr.%20Pimple%20Popper%20Removes%20a%20Lump%20the%20Size%20of%20a%20BABY%20From%20Man&#x27;s%20Shoulder&amp;body=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%253Futm_medium%3Dsharefromsite%2526utm_source%3Dthemusejezebel_email%26utm_campaign=top" title="Share via Email" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Mail icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M14.5 3A2.5 2.5 0 0 1 17 5.5v7a2.5 2.5 0 0 1-2.5 2.5h-11A2.5 2.5 0 0 1 1 12.5v-7A2.5 2.5 0 0 1 3.5 3h11zM2 5.5v7c0 .83.67 1.5 1.5 1.5h11c.83 0 1.5-.67 1.5-1.5v-7l-.03-.3-6.34 5.67a.5.5 0 0 1-.38.13.5.5 0 0 1-.38-.13l-6.7-6-.02-.02c-.1.2-.15.41-.15.64zM14.5 4h-11c-.24 0-.45.05-.65.14l6.4 5.73 6.19-5.54c-.26-.2-.58-.33-.93-.33z"></path></svg></span></span></a><a href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387" title="Share via Link" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Link icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M11.06 7.75a.5.5 0 1 1-.7.7l-.85-.83a1.86 1.86 0 0 0-2.63 0l-4 4a1.86 1.86 0 0 0 0 2.64l1.33 1.33c.72.73 1.91.72 2.64 0l1.8-1.8a.5.5 0 1 1 .7.7l-1.8 1.8a2.87 2.87 0 0 1-4.05 0l-1.33-1.32a2.86 2.86 0 0 1 0-4.05l4-4.01a2.86 2.86 0 0 1 4.05 0l.84.84zm5.17-4.41a2.86 2.86 0 0 1 0 4.05l-4 4.01a2.86 2.86 0 0 1-4.05 0l-.84-.84a.5.5 0 1 1 .7-.71l.85.84c.73.73 1.9.73 2.63 0l4-4c.73-.73.73-1.91 0-2.64l-1.33-1.33a1.87 1.87 0 0 0-2.64 0l-1.8 1.8a.5.5 0 1 1-.7-.7l1.8-1.8a2.87 2.87 0 0 1 4.05 0l1.33 1.32z"></path></svg></span></span></a></div></div><div class="post-tools-wrapper" data-state="{&quot;type&quot;:&quot;permalink&quot;,&quot;postId&quot;:&quot;1841066387&quot;,&quot;authorIds&quot;:[&quot;5722819797644708878&quot;],&quot;sharedToBlogId&quot;:null,&quot;status&quot;:&quot;PUBLISHED&quot;,&quot;postPermalink&quot;:&quot;https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387&quot;,&quot;wordCount&quot;:634,&quot;isFeatured&quot;:false,&quot;isVideo&quot;:false,&quot;isEmbiggened&quot;:true,&quot;parentId&quot;:null,&quot;parentAuthorId&quot;:null,&quot;defaultBlogId&quot;:&quot;1633941729&quot;,&quot;index&quot;:0,&quot;pageType&quot;:&quot;permalink&quot;,&quot;isDismissed&quot;:false,&quot;isBlocked&quot;:false}" data-post-id="1841066387" data-post-permalink="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387"><div class="sc-1vjnuu8-0 frTClM"><div class="sc-12i6d45-0 jzcQTJ"><div class="sc-12i6d45-1 cWiYXU"></div></div></div></div></div></div></div></div><div class="js_post-content r43lxo-0 kbNfCi"><figure class="align--bleed js_lazy-image js_marquee-assetfigure sc-1eow4w5-1 cKaaXC" data-id="dgw0lnnvff0fgkip7x84" data-recommend-id="image://dgw0lnnvff0fgkip7x84" data-format="Png" data-width="2534" data-height="1418" data-lightbox="true" data-recommended="true" contenteditable="false" draggable="false"><div class="img-wrapper sc-1eow4w5-2 gfolHV" contenteditable="false" style="max-width:2534px" data-syndicationrights="false"><span class="js_lightbox-wrapper sc-1eow4w5-0 dUoECc"><div class="magnifier js_lightbox lightbox hide sc-1m41dwj-0 hUFSvg"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="ZoomIn icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M10.5 1a6.5 6.5 0 1 1-4.23 11.44l-4.42 4.41a.5.5 0 0 1-.7-.7l4.41-4.42A6.5 6.5 0 0 1 10.5 1zm0 1a5.5 5.5 0 1 0 0 11 5.5 5.5 0 0 0 0-11zm0 2c.28 0 .5.22.5.5V7h2.5a.5.5 0 0 1 .5.41v.09a.5.5 0 0 1-.5.5H11v2.5a.5.5 0 0 1-.41.5h-.09a.5.5 0 0 1-.5-.5V8H7.5a.5.5 0 0 1-.5-.41V7.5c0-.28.22-.5.5-.5H10V4.5a.5.5 0 0 1 .41-.5z"></path></svg></span></div><div style="padding-bottom:56%" class="image-hydration-wrapper sc-1eow4w5-3 iJyiXs"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="dgw0lnnvff0fgkip7x84" data-format="png" data-height="1418" data-default-transform="UncroppedWideExtraLarge" data-width="2534" data-relative="false" data-show-background="true" data-alt="Illustration for article titled Dr. Pimple Popper Removes a Lump the Size of a BABY From Mans Shoulder" data-poster-src="" data-anim-src="" data-cropped="false" class="dv4r5q-1 hEuYft"/></div></div></span></div><span data-id="dgw0lnnvff0fgkip7x84" data-recommend-id="image://dgw0lnnvff0fgkip7x84" data-format="Png" data-width="2534" data-height="1418" data-lightbox="true" data-recommended="true" class="js_recommend"></span></figure><span></span><p class="sc-77igqf-0 hJpRRP">I put “BABY” in caps, because it’s a big baby. (And as a <span><a class="sc-145m8ut-0 hFUXcT js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Embedded Url&quot;,&quot;Internal link&quot;,&quot;https://jezebel.com/the-best-selectively-capitalized-daily-mail-headlines-o-1840610327&quot;,{&quot;metric25&quot;:1}]]" href="https://jezebel.com/the-best-selectively-capitalized-daily-mail-headlines-o-1840610327"><em>Daily Mail</em></a></span> hat tip, naturally.) Imagine: “Congrats! It’s a...lipoma.” Another successful <span><a class="sc-145m8ut-0 hFUXcT js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Embedded Url&quot;,&quot;Internal link&quot;,&quot;https://jezebel.com/tag/dr-pimple-popper&quot;,{&quot;metric25&quot;:1}]]" href="https://jezebel.com/tag/dr-pimple-popper"><em>Pimple Popper</em></a></span> delivery.</p><p class="sc-77igqf-0 hJpRRP">You have to see how they<!-- --> set up the plight of the man with the child in his shoulder:</p><div class="js_kinja-video sc-1jaa1bu-0 jWcsnW" id="185197" data-caption="[]"><div><div class="srp5v4-0 kqBBKi"><div data-vjs-player="true" class="srp5v4-1 kieQv"><video class="video-js" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/alwk26r6fqzpluf9tpwe.jpg" width="100%" height="100%"></video></div><div class="srp5v4-2 gPPElP"><svg class="icon" xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="PlayFilled icon" viewBox="0 0 18 18"><path fill="white" d="M5.3 16.7c-1.1.7-2.3 0-2.3-1.3V2.6c0-1.4 1.2-2 2.3-1.3l9.9 6.3c1 .7 1 2 0 2.7l-9.9 6.4z"/></svg></div></div></div></div><p class="sc-77igqf-0 hJpRRP">He can’t get through a door! He can’t put on a shirt! While I’m sure that carrying NINE POUNDS of lipoma on one’s shoulder is a considerable burden, the packaging here reminds me of the bumbling you see in infomercials for products that will magically improve your life. For many examples of these and our own amusement, let’s take a few minutes to revisit Everything Is Terrible’s classic supercut, Infomercial Hell:</p><div class="align--bleed has-video media-large video-embed embed-frame ooo3c9-0 ekkpks"><span class="flex-video widescreen"><iframe src="/ajax/inset/iframe?id=youtube-video-x7sLmbykZgs&amp;start=0" data-chomp-id="x7sLmbykZgs" data-recommend-id="youtube://x7sLmbykZgs" id="youtube-x7sLmbykZgs" data-recommended="false" width="800" height="450" class="core-inset" frameBorder="0" scrolling="no" allowfullscreen="" webkitallowfullscreen="webkitAllowFullScreen" mozallowfullscreen="mozallowfullscreen"></iframe><span data-chomp-id="x7sLmbykZgs" data-recommend-id="youtube://x7sLmbykZgs" id="youtube-x7sLmbykZgs" data-recommended="false" class="js_recommend"></span></span></div><p class="sc-77igqf-0 hJpRRP">Feels good to watch people ham up feeling bad.</p><p class="sc-77igqf-0 hJpRRP">I have already mentioned this several times, I realize, but it bears repeating that the lipoma that was in this man, 51-year-old Inoke, weighed <em>9 lbs.</em> The size of a big baby!</p><div class="js_kinja-video sc-1jaa1bu-0 jWcsnW" id="185198" data-caption="[]"><div><div class="srp5v4-0 kqBBKi"><div data-vjs-player="true" class="srp5v4-1 kieQv"><video class="video-js" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/boukxrtw1mpbvnnmfiz6.png" width="100%" height="100%"></video></div><div class="srp5v4-2 gPPElP"><svg class="icon" xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="PlayFilled icon" viewBox="0 0 18 18"><path fill="white" d="M5.3 16.7c-1.1.7-2.3 0-2.3-1.3V2.6c0-1.4 1.2-2 2.3-1.3l9.9 6.3c1 .7 1 2 0 2.7l-9.9 6.4z"/></svg></div></div></div></div><p class="sc-77igqf-0 hJpRRP">Elsewhere, we met Las Vegas resident Reed, who was besotted with steatocystoma near his chest. He said you could see it through his shirt, which threatened his aspirations of becoming a pizza chef.</p><div class="js_kinja-video sc-1jaa1bu-0 jWcsnW" id="185199" data-caption="[]"><div><div class="srp5v4-0 kqBBKi"><div data-vjs-player="true" class="srp5v4-1 kieQv"><video class="video-js" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/rysixfdxuwxwzf0sjkzi.png" width="100%" height="100%"></video></div><div class="srp5v4-2 gPPElP"><svg class="icon" xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="PlayFilled icon" viewBox="0 0 18 18"><path fill="white" d="M5.3 16.7c-1.1.7-2.3 0-2.3-1.3V2.6c0-1.4 1.2-2 2.3-1.3l9.9 6.3c1 .7 1 2 0 2.7l-9.9 6.4z"/></svg></div></div></div></div><p class="sc-77igqf-0 hJpRRP">“I don’t want people to think that I’m dirty, especially when I’m making their pizza,” is such a good capsule summary of a human that I’m tempted to steal it for my Twitter bio.</p><div is="bulbs-dfp" class="ad-container dfp dfp-slot-SPLASHYMID ad-splashy-mid" data-ad-unit="SPLASHYMID" data-targeting="{&quot;pos&quot;:&quot;splashymid&quot;}"></div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-TEADS_PERMALINK_OUTSTREAM ad-teads-outstream" data-ad-unit="TEADS_PERMALINK_OUTSTREAM" data-targeting="{&quot;pos&quot;:&quot;outstream&quot;}"></div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-SPLASHYMID_MOBILE ad-splashy-mid" data-ad-unit="SPLASHYMID_MOBILE" data-targeting="{&quot;pos&quot;:&quot;splashymid&quot;}"></div><div id="swappable-mobile-ad-container" class="js_ad-mobile-dynamic swappable-mobile-ad-container js_ad-dynamic ad-mobile-dynamic movable-ad bxm4mm-4 liWXlp"><div class="bxm4mm-1 bxm4mm-2 iXYVqp"></div><div class="ad-unit ad-mobile bxm4mm-5 eZvXLs"><div class="bxm4mm-6 eblHLt">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile js_swappable-mobile-ad" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-1 bxm4mm-3 dciqNP"></div></div><div class="instream-native-video instream-permalink instream-native-video--mobile bxm4mm-0 dVOasM"></div><p class="sc-77igqf-0 hJpRRP">Here a few reasons why you may want to watch the footage of Dr. PP extracting Reed’s steatocystomas: 1) They were numerous. 2) She compared them to butter...for your toast. 3) She then compared the entire output to a stick of butter. 4) Reed became entranced during this process and it is suggested that the popaholic in him has been awakened.</p><figure class="align--bleed js_lazy-image js_marquee-assetfigure sc-1eow4w5-1 cKaaXC" data-id="uhmqqcnl1lx9u8xtyjhv" data-recommend-id="image://uhmqqcnl1lx9u8xtyjhv" data-format="Png" data-width="2534" data-height="1418" data-lightbox="true" data-recommended="false" contenteditable="false" draggable="false"><div class="img-wrapper sc-1eow4w5-2 gfolHV" contenteditable="false" style="max-width:2534px" data-syndicationrights="false"><span class="js_lightbox-wrapper sc-1eow4w5-0 dUoECc"><div class="magnifier js_lightbox lightbox hide sc-1m41dwj-0 hUFSvg"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="ZoomIn icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M10.5 1a6.5 6.5 0 1 1-4.23 11.44l-4.42 4.41a.5.5 0 0 1-.7-.7l4.41-4.42A6.5 6.5 0 0 1 10.5 1zm0 1a5.5 5.5 0 1 0 0 11 5.5 5.5 0 0 0 0-11zm0 2c.28 0 .5.22.5.5V7h2.5a.5.5 0 0 1 .5.41v.09a.5.5 0 0 1-.5.5H11v2.5a.5.5 0 0 1-.41.5h-.09a.5.5 0 0 1-.5-.5V8H7.5a.5.5 0 0 1-.5-.41V7.5c0-.28.22-.5.5-.5H10V4.5a.5.5 0 0 1 .41-.5z"></path></svg></span></div><div style="padding-bottom:56%" class="image-hydration-wrapper sc-1eow4w5-3 iJyiXs"><div><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-chomp-id="uhmqqcnl1lx9u8xtyjhv" data-format="png" data-height="1418" data-default-transform="UncroppedWideExtraLarge" data-width="2534" data-relative="false" data-show-background="true" data-alt="Illustration for article titled Dr. Pimple Popper Removes a Lump the Size of a BABY From Mans Shoulder" data-poster-src="" data-anim-src="" data-cropped="false" class="dv4r5q-1 hEuYft"/></div></div></span></div><span data-id="uhmqqcnl1lx9u8xtyjhv" data-recommend-id="image://uhmqqcnl1lx9u8xtyjhv" data-format="Png" data-width="2534" data-height="1418" data-lightbox="true" data-recommended="false" class="js_recommend"></span></figure><div is="bulbs-dfp" class="ad-container dfp dfp-slot-SPLASHYMID_MOBILE ad-splashy-mid" data-ad-unit="SPLASHYMID_MOBILE" data-targeting="{&quot;pos&quot;:&quot;splashymid&quot;}"></div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-TEADS_PERMALINK_OUTSTREAM_MOBILE ad-teads-outstream" data-ad-unit="TEADS_PERMALINK_OUTSTREAM_MOBILE" data-targeting="{&quot;pos&quot;:&quot;outstream&quot;}"></div><p class="sc-77igqf-0 hJpRRP">Look at him beaming! I love when this show becomes about more than just the extreme things bodies to automatically—I love when it’s about the extreme human reactions to these extreme functions. Extreme on top of extreme! Extreme extremity! Reed lost a lot of pus but he gained an obsession. Madness.</p><p class="sc-77igqf-0 hJpRRP">And 5) Dr. Lee described the toll such extractions take on <em>her</em> body. This was a moment where we are asked to consider the popper.</p><div class="js_kinja-video sc-1jaa1bu-0 jWcsnW" id="185200" data-caption="[]"><div><div class="srp5v4-0 kqBBKi"><div data-vjs-player="true" class="srp5v4-1 kieQv"><video class="video-js" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/qnp6ngeqdbuhwvcut9mg.png" width="100%" height="100%"></video></div><div class="srp5v4-2 gPPElP"><svg class="icon" xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="PlayFilled icon" viewBox="0 0 18 18"><path fill="white" d="M5.3 16.7c-1.1.7-2.3 0-2.3-1.3V2.6c0-1.4 1.2-2 2.3-1.3l9.9 6.3c1 .7 1 2 0 2.7l-9.9 6.4z"/></svg></div></div></div></div><p class="sc-77igqf-0 hJpRRP">“My hands, my fingers, they’re exhausted,” explained Dr. PP. “Imagine if you’re typing on your keyboard, and instead of typing on it you had to squeeze each key hard, over and over again. It messes with your fingers, it messes with your head.” This really puts things into vivid perspective and I feel like I have a new appreciation for a woman that I have long admired. Bravo.</p><div id="" class="js_ad-mobile-dynamic  js_ad-dynamic ad-mobile-dynamic movable-ad bxm4mm-4 liWXlp"><div class="bxm4mm-1 bxm4mm-2 iXYVqp"></div><div class="ad-unit ad-mobile bxm4mm-5 eZvXLs"><div class="bxm4mm-6 eblHLt">Advertisement</div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-MOBILE_IN_POST ad-mobile" data-ad-unit="MOBILE_IN_POST" data-targeting="{&quot;pos&quot;:&quot;mobile_inpost&quot;}"></div><div class="bt-wrapper"><span data-uid="5d260804c9-384" class="bt-uid-tg" style="display:none !important;text-align:center" data-css-selector="ad-container.ad-mobile"></span></div></div><div class="bxm4mm-1 bxm4mm-3 dciqNP"></div></div><p class="sc-77igqf-0 hJpRRP">Finally, Dr. Lee checked back in with Delano, a man who was featured on the <span><a class="sc-145m8ut-0 hFUXcT js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Embedded Url&quot;,&quot;External link&quot;,&quot;https://www.tlc.com/tv-shows/dr-pimple-popper/full-episodes/dr-pimple-popper&quot;,{&quot;metric25&quot;:1}]]" href="https://www.tlc.com/tv-shows/dr-pimple-popper/full-episodes/dr-pimple-popper" target="_blank" rel="noopener noreferrer">very first episode</a></span> of this series (before it was a series, even, and was just presented as a one-off special). Delano had a hump on his back from which Dr. Lee removed almost a liter of fluid. She diagnosed it as a lymphangioma and said, on that episode, that it would come back. Well guess what? It did. The hump kept humping. And guess what else? Dr. Lee, like any wise person, recognized her limitations and knew that she couldn’t adequately treat Delano, so she sent him to a specialist, who removed the sac that had been holding the fluid, hopefully curing Delano of his debilitating hump once and for all.</p><div class="js_kinja-video sc-1jaa1bu-0 jWcsnW" id="185201" data-caption="[]"><div><div class="srp5v4-0 kqBBKi"><div data-vjs-player="true" class="srp5v4-1 kieQv"><video class="video-js" playsinline="" poster="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_450,q_80,w_800/lzhhaamzzkq3ovxlghbs.png" width="100%" height="100%"></video></div><div class="srp5v4-2 gPPElP"><svg class="icon" xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="PlayFilled icon" viewBox="0 0 18 18"><path fill="white" d="M5.3 16.7c-1.1.7-2.3 0-2.3-1.3V2.6c0-1.4 1.2-2 2.3-1.3l9.9 6.3c1 .7 1 2 0 2.7l-9.9 6.4z"/></svg></div></div></div></div><p class="sc-77igqf-0 hJpRRP">“It looks like Jello,” said Delano, and Dr. Lee kind of glossed over it because, I guess, making food analogies is her job and Delano was in her lane. But this is a joyous occasion nonetheless and I’m more convinced than ever that Dr. Pimple Popper is an angel who truly cares about her patients, even the ones she meets for the sake of making good television.</p></div><div class="sc-18b1b2r-5 hJcyvY"><div><h4 class="z1qon0-0 gxHlor">Share This Story</h4><div class="js_share-tools sc-18b1b2r-0 iwXbmg" data-position="bottom"><div class="sc-17x7c2u-3 dPaBUR"><a href="https://facebook.com/sharer.php?u=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3D_facebook" title="Share to Facebook" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Facebook icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M17 9.05A8.02 8.02 0 0 0 9 1C4.58 1 1 4.6 1 9.05A8.04 8.04 0 0 0 7.75 17v-5.62H5.72V9.05h2.03V7.28c0-2.02 1.2-3.14 3.02-3.14.88 0 1.8.16 1.8.16v1.98h-1.02c-.99 0-1.3.62-1.3 1.26v1.5h2.22l-.36 2.34h-1.86V17A8.04 8.04 0 0 0 17 9.05"></path></svg></span></span></a><a href="https://twitter.com/share?text=Dr.%20Pimple%20Popper%20Removes%20a%20Lump%20the%20Size%20of%20a%20BABY%20From%20Man&#x27;s%20Shoulder&amp;amp;url=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3D_twitter" title="Share to Twitter" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Twitter icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M12.46 1.13c-2.04 0-3.7 1.78-3.7 3.97 0 .31.04.62.1.9a10.26 10.26 0 0 1-7.6-4.15A4.2 4.2 0 0 0 2.4 7.16a3.5 3.5 0 0 1-1.68-.5v.05a3.92 3.92 0 0 0 2.97 3.9 3.45 3.45 0 0 1-1.67.07 3.74 3.74 0 0 0 3.45 2.76A7.08 7.08 0 0 1 0 15.1a9.92 9.92 0 0 0 5.66 1.79c6.8 0 10.5-6.06 10.5-11.32v-.51A7.85 7.85 0 0 0 18 2.99c-.66.32-1.37.53-2.12.63a3.95 3.95 0 0 0 1.62-2.2c-.71.45-1.5.78-2.34.96a3.57 3.57 0 0 0-2.7-1.25"></path></svg></span></span></a><a href="mailto:?subject=Dr.%20Pimple%20Popper%20Removes%20a%20Lump%20the%20Size%20of%20a%20BABY%20From%20Man&#x27;s%20Shoulder&amp;body=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%253Futm_medium%3Dsharefromsite%2526utm_source%3D_email%26utm_campaign=bottom" title="Share via Email" target="_blank" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Mail icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M14.5 3A2.5 2.5 0 0 1 17 5.5v7a2.5 2.5 0 0 1-2.5 2.5h-11A2.5 2.5 0 0 1 1 12.5v-7A2.5 2.5 0 0 1 3.5 3h11zM2 5.5v7c0 .83.67 1.5 1.5 1.5h11c.83 0 1.5-.67 1.5-1.5v-7l-.03-.3-6.34 5.67a.5.5 0 0 1-.38.13.5.5 0 0 1-.38-.13l-6.7-6-.02-.02c-.1.2-.15.41-.15.64zM14.5 4h-11c-.24 0-.45.05-.65.14l6.4 5.73 6.19-5.54c-.26-.2-.58-.33-.93-.33z"></path></svg></span></span></a><a href="https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387" title="Share via Link" class="sc-17x7c2u-0 gqhndK"><span class="sc-17x7c2u-1 jBsDWZ"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Link icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M11.06 7.75a.5.5 0 1 1-.7.7l-.85-.83a1.86 1.86 0 0 0-2.63 0l-4 4a1.86 1.86 0 0 0 0 2.64l1.33 1.33c.72.73 1.91.72 2.64 0l1.8-1.8a.5.5 0 1 1 .7.7l-1.8 1.8a2.87 2.87 0 0 1-4.05 0l-1.33-1.32a2.86 2.86 0 0 1 0-4.05l4-4.01a2.86 2.86 0 0 1 4.05 0l.84.84zm5.17-4.41a2.86 2.86 0 0 1 0 4.05l-4 4.01a2.86 2.86 0 0 1-4.05 0l-.84-.84a.5.5 0 1 1 .7-.71l.85.84c.73.73 1.9.73 2.63 0l4-4c.73-.73.73-1.91 0-2.64l-1.33-1.33a1.87 1.87 0 0 0-2.64 0l-1.8 1.8a.5.5 0 1 1-.7-.7l1.8-1.8a2.87 2.87 0 0 1 4.05 0l1.33 1.32z"></path></svg></span></span></a></div></div></div><div class="sc-18b1b2r-4 fwDNjy"><h4 class="z1qon0-0 gxHlor">Get our newsletter</h4><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Permalink page click&quot;,&quot;Subscribe button click&quot;]]" href="/newsletter" target="_blank"><button class="sc-18b1b2r-3 egRxyu j48i5d-2 eOMBOT"><div class="j48i5d-1 fbNnTF"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="MailFilled icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M17 5v8a2 2 0 0 1-2 2H3a2 2 0 0 1-2-2V5c0-.12.01-.24.03-.35L8.7 10.4a.5.5 0 0 0 .6 0l7.67-5.75c.02.11.03.23.03.35zm-2-2a2 2 0 0 1 1.54.72L9 9.37 1.46 3.72A2 2 0 0 1 3 3h12z"></path></svg></span><span class="j48i5d-0 hPQZPo">Subscribe</span></div></button></a></div></div><div class="js_liveblog-controls"></div><div class="js_qanda-controls"></div><div class="sc-1or3yyu-4 kSfANG"><h4 class="sc-1or3yyu-0 nBxoz">More from The Muse</h4><div class="sc-1or3yyu-3 hjalAF"><a class="sc-1or3yyu-2 bzrPWe js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Related Posts Module&quot;,&quot;Position 1 of 3&quot;,&quot;https://themuse.jezebel.com/dr-pimple-popper-and-the-third-testicle-that-actually-1840790829&quot;,{&quot;metric18&quot;:1}]]" href="https://themuse.jezebel.com/dr-pimple-popper-and-the-third-testicle-that-actually-1840790829"><h4 class="sc-1or3yyu-1 jcgXjw sc-759qgu-0 fwoJns">Dr. Pimple Popper and the Third Testicle That Actually Wasn't</h4></a></div><div class="sc-1or3yyu-3 hjalAF"><a class="sc-1or3yyu-2 bzrPWe js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Related Posts Module&quot;,&quot;Position 2 of 3&quot;,&quot;https://themuse.jezebel.com/pop-a-pimple-save-a-marriage-another-wacky-dr-pimpl-1840926762&quot;,{&quot;metric18&quot;:1}]]" href="https://themuse.jezebel.com/pop-a-pimple-save-a-marriage-another-wacky-dr-pimpl-1840926762"><h4 class="sc-1or3yyu-1 jcgXjw sc-759qgu-0 fwoJns">Pop a Pimple, Save a Marriage?: Another Wacky <i>Dr. Pimple Popper</i> Adventure</h4></a></div><div class="sc-1or3yyu-3 hjalAF"><a class="sc-1or3yyu-2 bzrPWe js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Related Posts Module&quot;,&quot;Position 3 of 3&quot;,&quot;https://themuse.jezebel.com/beauty-tips-from-someone-with-a-horses-hoof-growing-out-1836717506&quot;,{&quot;metric18&quot;:1}]]" href="https://themuse.jezebel.com/beauty-tips-from-someone-with-a-horses-hoof-growing-out-1836717506"><h4 class="sc-1or3yyu-1 jcgXjw sc-759qgu-0 fwoJns">Beauty Tips From Someone With a 'Horse Hoof' Growing Out of Her Head, on <i>Dr. Pimple Popper</i></h4></a></div></div><a name="replies"></a><div class="sc-73739c-0 fsIeMy"><div class="sc-1ib37xr-0 jKmkQD"><h4 class="z1qon0-0 gxHlor">About the author</h4><div><div class="sc-1ib37xr-1 jVTBel"><div class="sc-1ib37xr-2 fGHfot"><img data-src="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/kwtueajkkxrpcpjyw9nq.png" src="https://i.kinja-img.com/gawker-media/image/upload/c_fill,f_auto,fl_progressive,g_center,h_200,q_80,w_200/kwtueajkkxrpcpjyw9nq.png"/><a href="https://kinja.com/richjuz">Rich Juzwiak</a></div><div class="sc-1ib37xr-3 gQKnCU"><a href="https://kinja.com/richjuz">Rich Juzwiak</a><p>Some Pig. Terrific. Radiant. Humble.</p><div class="sc-1ib37xr-6 bXAuVO"><a href="mailto:rich@jezebel.com"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Mail icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M14.5 3A2.5 2.5 0 0 1 17 5.5v7a2.5 2.5 0 0 1-2.5 2.5h-11A2.5 2.5 0 0 1 1 12.5v-7A2.5 2.5 0 0 1 3.5 3h11zM2 5.5v7c0 .83.67 1.5 1.5 1.5h11c.83 0 1.5-.67 1.5-1.5v-7l-.03-.3-6.34 5.67a.5.5 0 0 1-.38.13.5.5 0 0 1-.38-.13l-6.7-6-.02-.02c-.1.2-.15.41-.15.64zM14.5 4h-11c-.24 0-.45.05-.65.14l6.4 5.73 6.19-5.54c-.26-.2-.58-.33-.93-.33z"></path></svg></span>Email</a><a href="https://twitter.com/richjuz"><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Twitter icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M12.46 1.13c-2.04 0-3.7 1.78-3.7 3.97 0 .31.04.62.1.9a10.26 10.26 0 0 1-7.6-4.15A4.2 4.2 0 0 0 2.4 7.16a3.5 3.5 0 0 1-1.68-.5v.05a3.92 3.92 0 0 0 2.97 3.9 3.45 3.45 0 0 1-1.67.07 3.74 3.74 0 0 0 3.45 2.76A7.08 7.08 0 0 1 0 15.1a9.92 9.92 0 0 0 5.66 1.79c6.8 0 10.5-6.06 10.5-11.32v-.51A7.85 7.85 0 0 0 18 2.99c-.66.32-1.37.53-2.12.63a3.95 3.95 0 0 0 1.62-2.2c-.71.45-1.5.78-2.34.96a3.57 3.57 0 0 0-2.7-1.25"></path></svg></span>Twitter</a><a href="https://kinja.com/richjuz"><span class="sc-1wnj9xm-1 cjCmmO ynl58c-0 tvyye"><svg xmlns="http://www.w3.org/2000/svg" width="64" height="64" aria-label="Kinja avatar" viewBox="0 0 64 64"><path fill-rule="evenodd" d="M17.6 34.47c1.02 1.7 7.35 12.36 9.5 16.08 2.38 4.1 5.7 4.45 7.55 4.45h13.49s-9.88-17.8-12.9-22.6c-2.03-3.26-4.74-3.64-7.76-3.64H9.33c-.03 0 2.94-3.54 9.48-3.76 6.54-.2 17.28.02 21.71 0s6.7-2.02 7.62-3.55C49.07 19.92 54.78 9 54.78 9H25.32c-3.95.02-5.67 2.12-7.18 4.61L9 28.65c-.03.05.02.23.06.32 0 0 1.14.06 2.87.6 2.44.8 4.65 3.21 5.67 4.9z"></path></svg></span>Posts</a></div></div></div></div></div></div><div class="js_postbottom-waypoint-hook"></div><div class="js_comments-iframe sc-73739c-1 bStdvX" data-src="//themuse.jezebel.com/embed/comments/magma/1841066387?comments_compact=on"><div></div></div><div class="sc-73739c-4 dBnbpo"><div id="taboola-below-article-thumbnails" class="sc-73739c-3 cEwyY"></div></div><div class="sc-1bdg1q0-0 dHZwOk"><div class="sc-1bdg1q0-2 cWglYt"><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Share Tools&quot;,&quot;Share to Facebook click&quot;,&quot;Share bar&quot;]]" href="https://facebook.com/sharer.php?u=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3D_facebook" target="_blank"><button class="sc-1bdg1q0-1 RFgyl j48i5d-2 gUlJSU"><div class="j48i5d-1 fbNnTF"><span class="j48i5d-0 hPQZPo">Share</span><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Facebook icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M17 9.05A8.02 8.02 0 0 0 9 1C4.58 1 1 4.6 1 9.05A8.04 8.04 0 0 0 7.75 17v-5.62H5.72V9.05h2.03V7.28c0-2.02 1.2-3.14 3.02-3.14.88 0 1.8.16 1.8.16v1.98h-1.02c-.99 0-1.3.62-1.3 1.26v1.5h2.22l-.36 2.34h-1.86V17A8.04 8.04 0 0 0 17 9.05"></path></svg></span></div></button></a><a class="js_link sc-1out364-0 fwjlmD" data-ga="[[&quot;Share Tools&quot;,&quot;Share to Twitter click&quot;,&quot;Share bar&quot;]]" href="https://twitter.com/share?text=Dr.%20Pimple%20Popper%20Removes%20a%20Lump%20the%20Size%20of%20a%20BABY%20From%20Man&#x27;s%20Shoulder&amp;amp;url=https%3A%2F%2Fthemuse.jezebel.com%2Fdr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387%3Futm_medium%3Dsharefromsite%26utm_source%3D_twitter" target="_blank"><button class="sc-1bdg1q0-1 RFgyl j48i5d-2 jetHlK"><div class="j48i5d-1 fbNnTF"><span class="j48i5d-0 hPQZPo">Tweet</span><span class="iyvn34-0 iSaTEN"><svg xmlns="http://www.w3.org/2000/svg" width="18" height="18" aria-label="Twitter icon" viewBox="0 0 18 18"><path fill-rule="evenodd" d="M12.46 1.13c-2.04 0-3.7 1.78-3.7 3.97 0 .31.04.62.1.9a10.26 10.26 0 0 1-7.6-4.15A4.2 4.2 0 0 0 2.4 7.16a3.5 3.5 0 0 1-1.68-.5v.05a3.92 3.92 0 0 0 2.97 3.9 3.45 3.45 0 0 1-1.67.07 3.74 3.74 0 0 0 3.45 2.76A7.08 7.08 0 0 1 0 15.1a9.92 9.92 0 0 0 5.66 1.79c6.8 0 10.5-6.06 10.5-11.32v-.51A7.85 7.85 0 0 0 18 2.99c-.66.32-1.37.53-2.12.63a3.95 3.95 0 0 0 1.62-2.2c-.71.45-1.5.78-2.34.96a3.57 3.57 0 0 0-2.7-1.25"></path></svg></span></div></button></a></div></div></div></div></main></div><div is="bulbs-dfp" class="ad-container dfp dfp-slot-INFINITE_PROMOTION ad-infinite-promotion" data-ad-unit="INFINITE_PROMOTION" data-pp-position="scroll" data-targeting="{&quot;pos&quot;:&quot;scroll&quot;,&quot;pp_position&quot;:&quot;scroll&quot;}"></div><div class="js_reading-list"></div><div class="js_subscribe sc-1cfejv7-0 iHpzjB"></div><div class="js_footer-container"></div><div class="js_lightbox-container"></div></div><script>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</script><script>window.kinja = {
				meta: {"blog":{"id":"1633941729","name":"themusejezebel","displayName":"The Muse","canonicalHost":"themuse.jezebel.com","hosts":["themusejezebel.kinja.com","themuse.kinja.com"],"status":"ENABLED","timezone":"America/New_York","timezoneOffset":-18000000,"createTimeMillis":1411744619764,"ownerId":"5876237249234973238","description":"Obsessed Culture","properties":{"facebookScreenName":"jezebel","groupBlog":true,"logoLink":"https://x.kinja-static.com/assets/images/logos/newsletter/jezebel-500px.png","aboutPostId":5732075,"navigationGroup":"fmg","recircGroup":"fmgNonSatire","twitterScreenName":"@jezebel","hideViewcounts":true,"facebookPixelId":"303148120176875","singleOptIn":true,"chartbeatPopularPosts":true,"autoRepostToParent":true,"cxenseSiteId":"1140750538956086803","robotsAllowed":true,"isGmgBlog":true,"youtubeUrl":"https://www.youtube.com/jezebel","instagramScreenName":"jezebel","blogGroup":"jezebel","sourcepointDomain":"mms.jezebel.com","googleAnalyticsID":"UA-142218-20","newsletter":true,"campaignMonitorNewsletterName":"Jezebel_Daily","adsTxtEnabled":false},"parentId":"39","avatar":{"id":"auj4p7qsrkznkdstuufo","format":"png","isAnimated":false,"frozenFormat":"png"},"logo":{"id":"qrpfzmyxc9etccmtvctc","format":"png","isAnimated":false,"frozenFormat":"png"},"facebookScreenName":"jezebel","groupBlog":true,"logoLink":"https://x.kinja-static.com/assets/images/logos/newsletter/jezebel-500px.png","aboutPostId":5732075,"navigationGroup":"fmg","recircGroup":"fmgNonSatire","twitterScreenName":"@jezebel","hideViewcounts":true,"facebookPixelId":"303148120176875","singleOptIn":true,"chartbeatPopularPosts":true,"autoRepostToParent":true,"cxenseSiteId":"1140750538956086803","robotsAllowed":true,"isGmgBlog":true,"youtubeUrl":"https://www.youtube.com/jezebel","instagramScreenName":"jezebel","blogGroup":"jezebel","sourcepointDomain":"mms.jezebel.com","googleAnalyticsID":"UA-142218-20","newsletter":true,"campaignMonitorNewsletterName":"Jezebel_Daily","adsTxtEnabled":false},"syncFeatures":"","customFeatures":[],"post":{"author":{"displayName":"Rich Juzwiak"},"gaDimensions":{"gaVideoIds":"kinjavideo-185197,youtube-video-x7sLmbykZgs,kinjavideo-185198,kinjavideo-185199,kinjavideo-185200,kinjavideo-185201","wordCount":634,"wordCountBucket":"600 - 800"},"headline":"Dr. Pimple Popper Removes a Lump the Size of a BABY From Man's Shoulder","id":"1841066387","isFeatured":false,"isVideo":false,"isSlideshow":false,"slideIndex":null,"permalink":"https://themuse.jezebel.com/dr-pimple-popper-removes-a-lump-the-size-of-a-baby-fro-1841066387","postPosition":0,"publishTimeMillis":1579291200387,"sponsored":false,"isStarter":true,"starterId":"1841066387","storyType":{"title":"Television","id":"1287"},"tags":[{"canonical":"drpimplepopper","urlName":"dr-pimple-popper","displayName":"Dr. Pimple Popper"},{"canonical":"tlc","urlName":"tlc","displayName":"TLC"},{"canonical":"realitytv","urlName":"reality-tv","displayName":"Reality TV"}],"truncation":false,"videos":[{"id":null,"type":"kinjavideo","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"alwk26r6fqzpluf9tpwe","format":"jpg","width":0,"height":0,"id":"alwk26r6fqzpluf9tpwe","frozenFormat":"jpg"}]},{"id":null,"type":"youtube","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"k8c1mqcoiao6bjiwv7f4","format":"jpg","width":0,"height":0,"id":"k8c1mqcoiao6bjiwv7f4","frozenFormat":"jpg"}]},{"id":null,"type":"kinjavideo","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"hqp0dzfr33gsytnxzu04","format":"png","width":0,"height":0,"id":"hqp0dzfr33gsytnxzu04","frozenFormat":"png"}]},{"id":null,"type":"kinjavideo","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"vnemzi4ladgvlgu3n7mv","format":"png","width":0,"height":0,"id":"vnemzi4ladgvlgu3n7mv","frozenFormat":"png"}]},{"id":null,"type":"kinjavideo","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"wdh3y5c1vohvilhfsa3i","format":"png","width":0,"height":0,"id":"wdh3y5c1vohvilhfsa3i","frozenFormat":"png"}]},{"id":null,"type":"kinjavideo","embedCode":null,"height":null,"width":null,"thumbnails":[{"uid":"pzgfxyi6ck0uxuhwnhob","format":"png","width":0,"height":0,"id":"pzgfxyi6ck0uxuhwnhob","frozenFormat":"png"}]}]},"blogSales":{"id":"1633941729","amazonInsetsEnabled":true,"amazonAffiliateTag":"jezebelamzn-20","adsEnabled":true,"adNetworkId":4246,"adSiteName":"gm.jezebel","indexExchangeWebSiteId":"21311668852735","indexExchangeAmpSiteId":"272209","bouncexId":"3593","blogNetworkId":null,"tagsExcludedFromPartnerRss":[],"tagsForceSynced":[],"adSlotsDisabled":[]},"pageType":"permalink","environmentDesc":"production:magma","isScrollActive":false},
				categoryMeta: {"categories":"television"},
				tagMeta: {"tags":"dr pimple popper,tlc,reality tv"}
			};</script><script async="" src="/x-kinja-static/assets/new-client/runtime~ads.54484ea6a0a90bf7d28d.js"></script><script async="" src="/x-kinja-static/assets/new-client/vendors~ads.bbd1c98eb9684ebd4e66.js"></script><script async="" src="/x-kinja-static/assets/new-client/ads.a9d21ac22e9ec89e977d.js"></script><script async="" src="/x-kinja-static/assets/new-client/runtime~trackers.83877260061b4d6ce009.js"></script><script async="" src="/x-kinja-static/assets/new-client/categoryPage~curatedHomepage~errorPage~experiments~featuredPermalinkPage~frontPage~newsletterPage~pe~272cce46.fce39101c2be19473e2b.js"></script><script async="" src="/x-kinja-static/assets/new-client/trackers.a26de33bbc90724e7d3e.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/runtime~permalinkPage.71683080ed58798e3839.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~curatedHomepage~errorPage~experiments~featuredPermalinkPage~frontPage~newslette~7c197509.23208bd49c4659e5ae07.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~curatedHomepage~errorPage~experiments~featuredPermalinkPage~frontPage~newslette~8c7a710b.ff43dc74383744cfe5da.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~featuredPermalinkPage~frontPage~header~homepage-edit~lunchbox-read-only-compone~d7617978.430fcd097136dd041ee2.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~curatedHomepage~featuredPermalinkPage~frontPage~header~login~permalinkPage~prof~85d27d59.41fe7b495bcf7b06877f.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~featuredPermalinkPage~frontPage~header~permalinkPage~profilePage~slideshowPerma~18fa7afe.8d32889e1f0f94ce5dd2.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~curatedHomepage~featuredPermalinkPage~frontPage~lunchbox-read-only-component~pe~fb29c5e5.7047dca427a4aaf15005.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~featuredPermalinkPage~frontPage~homepage-edit~lunchbox-read-only-component~perm~4874bdc4.e7c58926257f45606269.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~experiments~featuredPermalinkPage~frontPage~permalinkPage~profilePage~slideshow~c6edef2f.35c4b8cb726fc0cd614b.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/vendors~categoryPage~curatedHomepage~featuredPermalinkPage~frontPage~permalinkPage~searchPage~slides~a3dad056.1ca74791484faebe15d4.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~experiments~featuredPermalinkPage~footer~frontPage~header~homepage-edit~login~lunchbox-~6715796b.6f95bd2f85faa61ce4ca.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~experiments~featuredPermalinkPage~frontPage~header~homepage-edit~login~lunchbox-read-on~4cc8eac3.247a50d86d3286347dae.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~curatedHomepage~errorPage~experiments~featuredPermalinkPage~frontPage~newsletterPage~pe~60491655.ff752591b79a8c1a5a79.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~curatedHomepage~errorPage~experiments~featuredPermalinkPage~frontPage~newsletterPage~pe~cec53442.e5f04f12a4f5f354ccb1.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~experiments~featuredPermalinkPage~frontPage~header~permalinkPage~profilePage~search~sli~2d07217a.398797b62ebfccb1959e.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~experiments~featuredPermalinkPage~frontPage~header~permalinkPage~profilePage~slideshowP~778a758f.1f70804fdc862b12cc56.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/categoryPage~curatedHomepage~experiments~featuredPermalinkPage~frontPage~header~permalinkPage~profil~e45eac79.1a3150960b39bea73d03.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/video-player.c2daf48b3d6817deb4a3.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/featuredPermalinkPage~frontPage~homepage-edit~permalinkPage~profilePage~searchPage~slideshowPermalin~2e25eb10.5faaaaf110642a85daee.js"></script><script async="" src="//x.kinja-static.com/assets/new-client/permalinkPage.5c7329808fca0b037b04.js"></script><div class="js_modal"></div><div id="kinja-bucket-setter"></div></body></html>